为Iceweasel安装Google Toolbar

此页由Linux Wiki用户Chenxing于2008年9月27日 (星期六) 08:31的最后更改。 在ruicong的工作基础上。

出自Linux Wiki

提示:此文已超过 6 年(2448 天)未更新,如发现内容过时或有误,欢迎改进:)

由于版权原因,Debian把Firefox更名为Iceweasel发行,由此给用户带来的一个问题便是不能正常安装Google Toolbar。

Hint.gif
提示:
安装Alexa的工具条的方法与此完全类似。

目录

原因简析

用于Firefox的Google工具栏(Google Toolbar for Firefox)要求使用Firefox 1.5或更高版本,实现方法是在下载前检查浏览器提供的User Agent变量。Iceweasel名称上不是Firefox,所以被Google识别为版本不符。

解决方案

提供几种解决方案,可以任选。

更改User Agent变量

从地址栏进入about:config,把general.useragent.extra.firefox值中的Iceweasel更改为Firefox即可。(推荐此种方法,因为它对其它使用useragent判断浏览器的网页也有用)

直接下载插件

这似乎是不可思议的方法,但确实可行。下载(注意是下载,即保存到本地而非直接点) http://dl.google.com/firefox/google-toolbar-linux.xpi

把它直接拖到浏览器窗口里就可以了。该插件不再检查浏览器是Firefox还是Iceweasel。

参考资料

本文对您有帮助?分享给更多朋友!

反馈与讨论

发现文档不全面、有错误却没时间编辑文档?想分享自己的经验或见解?欢迎在此留言、讨论。
个人工具
简体繁体转换