Google Gadgets for Linux及其編譯安裝

此頁由 Linux Wiki用戶Chenxing 於 2008年6月6日 (星期五) 05:37 的最後更改。

出自Linux Wiki

提示:此文已超过 8 年(3104 天)未更新,如发现内容过时或有误,欢迎改进:)

本文介紹在Linux中運行Google Gadgets的軟件及其編譯安裝方法。

目錄

軟件介紹

Google Gadgets for Linux 可以在Linux中運行Google桌面小工具的開源軟件,有使用GTK和Qt的兩種前端,可以配合Compiz達到很好的效果。[1]

邊欄模式的屏幕截圖,點擊可放大
普通模式的截圖,來自ggl的網站

安裝方法

由於該軟件還處於測試階段,目前只能編譯安裝。

Note.gif
TODO:
編寫在Fedora等系統內的編譯安裝方法。

Ubuntu或Debian系統

該方法已被確認適用於Ubuntu 8.04和Debian Sid。

Note.gif
TODO:
Debian其它版本可否用此法安裝?

準備工作

安裝編譯需要的庫[2]

$ sudo apt-get install libgtk2.0-dev libmozjs-dev libxul-dev \
 libcurl4-openssl-dev libgstreamer0.10-dev\
 libgstreamer-plugins-base0.10-dev libdbus-1-dev \
 libxml2-dev librsvg2-dev  spidermonkey-bin

下載程序的源碼包(請最好到其下載頁面選擇最新版下載)。2008年6月6日的版本可點此下載

編譯

由於編譯的依賴關係已經解決,編譯過程就沒有什麼特殊的了。

Hint.gif
提示:
可以參考編譯安裝軟件的一般方法

解開源碼包並進入源碼目錄:

tar xvfz google-gadgets-for-linux-*.tar.gz
cd google-gadgets-for-linux-*

執行一般的編譯過程(需要一段時間):

./configure --prefix=/usr
make
sudo make install

使用

現在就可以運行Google Gadgets for Linux了(建議和Compiz Fusion一起使用),gtk版的運行方式是:

$ ggl-gtk

如果要以邊欄模式運行,則運行:

$ ggl-gtk -s
Note.gif
注意:
如果configure時忘了加--prefix那個參數,可能出現執行時報告找不到庫文件的錯誤,此時可以運行sudo ldconfig以解決問題。

Fedora 9的注意事項

由於Fedora 9的js-1.70有問題,正常編譯會出錯,請參照這篇文章打個補丁(可按第三步、第二步的順序),接着安裝需要的包,最後再編譯。[3]

參考資料

  1. http://code.google.com/p/google-gadgets-for-linux/
  2. http://code.google.com/p/google-gadgets-for-linux/wiki/FAQ
  3. http://code.google.com/p/google-gadgets-for-linux/issues/detail?id=105

本文对您有帮助?分享给更多朋友!

反馈与讨论

发现文档不全面、有错误却没时间编辑文档?想分享自己的经验或见解?欢迎在此留言、讨论。
简体繁体转换